Jump to content
Sign in to follow this  
Juha Holopainen

TopSky plugin beta poll

TopSky plugin beta poll  

27 members have voted

You do not have permission to vote in this poll, or see the poll results. Please sign in or register to vote in this poll.

Recommended Posts

It's now been a while without any reported issues with the beta plugin. While no news can be good news, I've set up this poll to gather at least some data to support it. Please answer the poll regardless of whether you use the beta or not so I can get an idea of how much it is being used and if there is something that still needs attention.

The current development version has very few changes to the latest beta. The settings files can now contain preset window states and positions, and the main settings file can now contain callsign-specific settings (previously limited to the "SettingsLocal" file). The idea behind this change is to have all the settings provided in a controller package in the main settings file, leaving the "SettingsLocal" file for personal settings (such as window preferences).

If you don't know if you're using the beta or not, check it from the EuroScope OTHER SET menu -> Plug-ins... -> see the Version number of the TopSky plugin. If it starts with "2.2b", you're using the beta.

If there are issues, please bring them to my attention, either here or in the dedicated issues thread on the Finland subforum. If you're not happy to voice your concerns publicly, a private message is fine as well. If there's a specific reason you only occasionally use the beta, or have stopped using it, I'd like to hear it as well, unless it's "I don't want to use beta software". It's a perfectly valid reason, but as it doesn't tell anything about the plugin's readiness for release, I don't need to know it.

Edited by Juha Holopainen
  • Like 1

Share this post


Link to post
Share on other sites

Now that there's a vote for issues needing to be fixed, I'd like to have a look them. The problem is that I haven't got a clue what to look for as I haven't received any details about the issue(s). The vote may have been unintentional, but if it wasn't, the chances of anything getting fixed is pretty low until I know more about it.

Share this post


Link to post
Share on other sites

Version 2.2 of the TopSky plugin is now released.

The release version can be downloaded from http://www.saunalahti.fi/~juholoc/EuroScope/plugins/TopSky.zip (this is the URL shown by the plugin's update check system). This package contains the plugin dll, the manual sets and the two data files that can be used with any setup (no local settings or data files). Users of the beta version can safely switch to the release version, but anyone still using the previous release version (2.1.1) should probably wait until their controller package is updated with the new version since some items in the setup may need to be adjusted to be perfectly compatible with the new plugin.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×