Jump to content
Juha Holopainen

Plugin updates

Recommended Posts

From what I've been able to tell, in COOPANS the Map_3 colour is used to display airways, but "beacons" such as fixes and navaids use the brighter Beacon colour.

By the way, is it possible to set it up so that fixes/navaids/airports as displayed through the Maps menu are toggled on/off at startup?

Share this post


Link to post
Share on other sites

The state of the auto-generated maps in the MISC folder can not be directly set at startup, as the sector file based maps haven't been generated when the settings files are read. However, a workaround exists. For example defining

[_]
Setup_LoadMap=MISC\FIXES ALL + L

in the settings file loads that map whenever any callsign containing the underscore character is used. That's almost as good as the map loading automatically on startup. Other more specific callsign-based settings can of course also be used.

  • Thanks 1

Share this post


Link to post
Share on other sites

The Ground Radar plugin has a small update as well:

Ground Radar plugin 1.2.1

This should fix some plugin window scrollbar issues and a couple of safety nets which erroneously required the radar track to be correlated even when the normal "non-pro" mode was used. The safety nets should now get the same information about the tracks that is displayed to the controller.

The plugin update system will notify about the update as well, but it may be more convenient to use the link above as the plugin's message box does not contain a link, just a text displaying the download location.

  • Like 2

Share this post


Link to post
Share on other sites

That's great!

Has there been any updates to the cargo callsigns? I've added NPT and GTI myself as they were not on the list.

Share this post


Link to post
Share on other sites

Yes, the cargo callsigns data file has been updated. However, creating and updating the file has been a manual process so it is in no way a comprehensive list, just a bit better than nothing at all. Suggestions of changes are welcome, but only currently active real operators please in order to avoid conflicts.

edit: the plugin package is now updated with a new cargo callsigns data file containing the two callsigns above and a number of others

Edited by Juha Holopainen
  • Thanks 1

Share this post


Link to post
Share on other sites

@Juha Holopainen

Having problems with the Datalink PDC/DCL when manning ESOS_CTR. I receive the request, the yellow "REQ" disappears after half a second and I can not send the clearence. When opening "DEP CLEARENCE-Window" it only shows as the normal window without the datalink/rtf option. Only happens when manning ESOS, on regional sectors it works just fine. Any ideas?

 

I tried sending clearence to myself using the Hoppie MSFS-Client, the system sends the "REQUEST BEING PROCESSED STANDBY"-Message, but then everything happens as above

Edited by Max August Larsson Kuhla
Spelling and adding clarification

Share this post


Link to post
Share on other sites

Which plugin version has the issues? If more than one, any idea which version was the last one where it worked properly? The latest beta had some changes in this area so I may have broken something there.

I’ll have a look at the code, but I won’t be able to do so until sometime next week. Hopefully it’s something simple as troubleshooting the datalink system is a bit tricky.

Share this post


Link to post
Share on other sites

Working fine on other positions, only having problems when manning ESOS_CTR/ESOS_1_CTR with logon ESOS

2.2.1b5 (Having same problems on version b4)

EDIT:

After reasoning and testing with some other controllers getting it to work on other positions, maybe the problem is me running ES r19, I'll check tomorrow if it works with an older beta version (Should not make a difference right? But I'll try anyways)

Edited by Max August Larsson Kuhla

Share this post


Link to post
Share on other sites

Got some error messages after updating:

I'm guessing it has something to do with this new ring that Petter and Martin created around "Bällsta" to allow 3Nm sep, since the ring doesnt show.
As soon as I press reload though, everything is fine with the settings. MSAW still yellow and creates an alert

57170694_319531415378399_5130204122854719488_n.png

57511543_614801275652574_2315039844159455232_n.png

57882563_317767132229669_1489404687277883392_n.png

Share this post


Link to post
Share on other sites

MSAW “no data” being yellow is as intended for a situation where the MSAW system is selected on in the plugin, but there is no data in the data file, or the file does not exist. It’s just pointing out that you are never going to get an MSAW alert in this situation.

For the other issue, since the Maps data file doesn’t report any issues, the maps are probably defined ok. Why the settings file then has an issue with activating the map, at this point I don’t know, since apparently all the other maps set to activate in the settings file activate just fine? (the displayed error message means that the requested map doesn’t exist)

  • Thanks 1

Share this post


Link to post
Share on other sites

Found the cause and solution to my DCL-Problem!

Running several instances of ES with the Topsky-plugin and several DEP-Lists caused problems. Only using having DEP-List open on the main instance seemed to solve this issue. Any posibility to make it usable on several instances?

Share this post


Link to post
Share on other sites
3 hours ago, Juha Holopainen said:

For the other issue, since the Maps data file doesn’t report any issues, the maps are probably defined ok. Why the settings file then has an issue with activating the map, at this point I don’t know, since apparently all the other maps set to activate in the settings file activate just fine? (the displayed error message means that the requested map doesn’t exist)

It shows up with "bad data" on ES startup, but after reloading the settings either by clicking the button in the Plugin Status menu, or by logging on at an active position, the "bad data" message is gone, and the ring displays.

@Martin Stockzell MSAW is not active in Sweden (as in real life). I suppose we can de-activate it by default to avoid the yellow error message, or what do you say @Petter Jakobsson?

  • Thanks 1

Share this post


Link to post
Share on other sites
8 hours ago, Martin Loxbo said:

It shows up with "bad data" on ES startup, but after reloading the settings either by clicking the button in the Plugin Status menu, or by logging on at an active position, the "bad data" message is gone, and the ring displays.

@Martin Stockzell MSAW is not active in Sweden (as in real life). I suppose we can de-activate it by default to avoid the yellow error message, or what do you say @Petter Jakobsson?

Ah good to know regarding the settings thing. At least I know that I havn't mucked anything in the settings file myself :) Since a reload did fix the error, however MSAW still gave my an alert. But then I know that it's safe to update!

Share this post


Link to post
Share on other sites

Another update to TopSky:

TopSky 2.2.1 beta 6

Changes from beta 5 include:

  • Fixes in the datalink code. It is now possible to have DEP lists open on multiple instances and still have the DCL/PDC functionality working. The message timers are available only on the primary instance however so the indications will not start blinking shortly before timeout occurs on the proxy instances. A message formatting issue arising in certain conditions causing the clearance message to get rejected by the Hoppie server is also fixed.
  • Map activation using settings fixed
  • Specific colors added to auto-generated maps
  • NAT Track Messages Window and related auto-generated maps added
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Sorry for being so useless, guess I didn´t rtfm :P. Can anyone tell me whether or not I can change the color of an airway with COOPANS=0?

Kind Regards

Share this post


Link to post
Share on other sites
33 minutes ago, Fraser Cooper said:

Hello all,

I am having an issue with the plugin. It seems in the download, there is only a .ddl plugin and a excel spreadsheet. However, when I load the plugin there is not data in the plugin status.

http://prntscr.com/oxkyfv

http://prntscr.com/oxkyyi

Any help would be appreciated.

Fraser

Regarding the MSAW I think the problem is the same I had before. Just add MSAW=0 or something similar to TopSkySettings.txt and it shouldnt nag about it. Check the discussion above.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...